پرش به


تصویر

مشکل حرف (و)


  • لطفا وارد حساب کاربری خود شوید تا بتوانید پاسخ دهید
18 پاسخ برای این موضوع

#1 p30well

p30well

    عضو سایت

  • عضو سایت
  • ستارهستاره
  • 75 ارسال

ارسالی 1388/04/22 ساعت 15:10

سلام

داشتم با سایتم کار میکردم که یه دفته وقتی بازش کردم دیدم که یه مشکلی پیش اومده و اونم اینه که همه ی حرف های (و) تبدیل شدن به (�?)!!!!!!!!!!!!!!!!!!!!!!!

خودتون میتونید سایتمو ببینید! اما حالا که مطلبی رو اضافه میکنم حرف (و) کاملا درست ذخیره میشه!
میشه بگید مشکل چیه؟
  • 0

#2 mob2ni

mob2ni

    کاربر فعال انجمن

  • عضو سایت
  • ستارهستارهستاره
  • 208 ارسال

ارسالی 1388/04/22 ساعت 15:16

بله مشکل بنده هم درست همینه مدیر سایت اقای ساحر عرض کردن که دوباره قالب رو آپ کن و من دارم این کار رو انجام میدم
  • 0

#3 Guest_Saher_*

Guest_Saher_*
  • میهمان

ارسالی 1388/04/22 ساعت 15:27

mob2ni,
شما فقط قالبتون این طوری می شه یا همه جا همین جوریه!؟

p30well,
بعد از آپگرید اینجوری شده؟ همین طوری اینجوری نمی شه یه کاری کردید؟ اگر بعد از آپگرید اینجوری شده جوابش توی پرسش های متداول هست ولی چون صفحش باز نمی شه تو سایت همین جا بهتون می گم باید بک آپی را که گرفتید خودتون کامل ویرایش کنید و تمامی علامت های سوال را به و تبدیل کنید و کاراکترهای اضافی را پاک کنید و بک آپ را اون وقت utf8 آپ کنید و بعد توی engine/data/dbconfig.php مقدار charest را روی utf8 بذارید
  • 0

#4 mob2ni

mob2ni

    کاربر فعال انجمن

  • عضو سایت
  • ستارهستارهستاره
  • 208 ارسال

ارسالی 1388/04/22 ساعت 15:36

عرض کردم نه تنها قالب بلکه تمام پست ها به طور کامل سایت ریخته بهم و درست عین مشکل بالایی فقط حرف و به مربع و غلامت سوال تبدیل شده است . عرض کردم کاری انجام داده نشده فقط زمانی که licence سی =نل به اتمام رسیده بود و باید هاستینگ پول را پرداخت می کرد ریخته بود به هم و بعد از پرداخت پول و حل مشکل باز هم به همین صورت ریخته بهم
  • 0

#5 mob2ni

mob2ni

    کاربر فعال انجمن

  • عضو سایت
  • ستارهستارهستاره
  • 208 ارسال

ارسالی 1388/04/22 ساعت 15:43

بنده آپگرید نکردم و این مشکل رو دارم ؟ و دست به تنظیماتم نزدم فقط بعد قطع و وصلی هاستینگ این مشکل برام پیش آمده که با مراجع به سایتم می بینین کل سایت زبونش ریخته بهم ؟ حالا بنده چی کار کنم ؟ (توضیح دادم چون بالا توضیح نداده بودم )
  • 0

#6 p30well

p30well

    عضو سایت

  • عضو سایت
  • ستارهستاره
  • 75 ارسال

ارسالی 1388/04/22 ساعت 17:48

بازم سلام!
من اومدم تا بگم این مشکل برای من هم درست بعد از قعط و وصلی هاست ایجاد شده!
اگر دقت کنید توی قالبم همه حروف و درسته ولی هر و که توی دیتابیس هست اینطوری شده!


..
..
..
میشه راهنمایی کنید بگید میونبری چیزی وجود نداره که من (و) توی 200تا مطلب رو درست کنم؟
  • 0

#7 p30well

p30well

    عضو سایت

  • عضو سایت
  • ستارهستاره
  • 75 ارسال

ارسالی 1388/04/22 ساعت 18:05

این رو هم متذکر بشم که من آپگرید نکردم و دیتالایف انجین 8 رو همون اول نصب کردم!

اگر میشه یک مختصر راهنمایی راجع به تبدیل کاراکتر ست به utf8 بکنید.

ممنون
  • 0

#8 Guest_Saher_*

Guest_Saher_*
  • میهمان

ارسالی 1388/04/22 ساعت 22:48

mob2ni,
یا شما اشتباه عرض کردید و یا من اشتباه متوجه شدم

iliadmoosavi,
دوست عزیز ببخشید خواهشا نظرتون رو پیش خودتون نگه دارید چون ازین راه مشکلشون درست حل نمی شه (پستتون حذف شد)

p30well,
ببنید شما و mob2ni باید همون اول روی utf8 می گذاشتید دیتابیس را الان یه کم دردسر داره ولی شدنی هست! ببنید اول از همه از حالت فعلی یه بک آپ کامل دیتابیس بگیرید و دانلود کنید حالا با نوت پد پلاس encoding فایل را روی ansi as utf8 بگذارید و بعد تمامی علامت های سوال که به فارسی هستید یعنی این ((؟)) نه این ===> ((?)) را با find>Replace all به ((و)) تغییر بدید و بعد ذخیره کنید و یه دیتابیس جدید با colation : utf8_general_ci بسازید و دیتابیس را اونجا import کنید (البته دیگه خودتون می دونید که باید یوزر به دیتابیس بدید و ...) حال فایل engine/data/dbconfig.php را باز کنید و مشخصات دیتابیس جدید را وارد کنید و به جای cp1251 وارد کنید utf8
  • 0

#9 p30well

p30well

    عضو سایت

  • عضو سایت
  • ستارهستاره
  • 75 ارسال

ارسالی 1388/04/22 ساعت 23:32

من سعی میکنم ولی خودتون یه نگان بندازید! اینجا هیچ علامت سوالی وجود نداره! همش حرف های عجیبه!
 title=


راه دیگه ای نداره؟؟؟؟

  • 0

#10 Guest_Saher_*

Guest_Saher_*
  • میهمان

ارسالی 1388/04/23 ساعت 00:42

عزیز من بک آپ بگیر کارت نباشه! نتونستی یوزر و پس را بده من
  • 0

#11 p30well

p30well

    عضو سایت

  • عضو سایت
  • ستارهستاره
  • 75 ارسال

ارسالی 1388/04/23 ساعت 00:49

من نمیتونم به شما پیغام خصوصی بدم! آخه این قالب سایتتون یکم مشکل داره! آیدی من رو اد کنید! منتظرم: [email protected]
  • 0

#12 p30well

p30well

    عضو سایت

  • عضو سایت
  • ستارهستاره
  • 75 ارسال

ارسالی 1388/04/23 ساعت 01:41

واقعا ممنون از کمکت ساحر جان! از اینکه این وقت شب به دادم رسیدی و مشکل جدی سایتمو حل کردی!

تا وقتی یک دوست مثل تو تو این انجمن فعالیت میکنه هیچکی هیچ مشکلی براش پیش نمیاد love
  • 0

#13 Guest_Saher_*

Guest_Saher_*
  • میهمان

ارسالی 1388/04/23 ساعت 01:56

این از p30well حالا شما mob2ni اگه می خوای مشکل بر طرف شه!
  • 0

#14 Guest_Saher_*

Guest_Saher_*
  • میهمان

ارسالی 1388/04/23 ساعت 11:18

Temp2ni,
برادر من به این راحتی ها هم نیست نظرتون محترم پیش خودتون نگرش دارید
  • 0

#15 mob2ni

mob2ni

    کاربر فعال انجمن

  • عضو سایت
  • ستارهستارهستاره
  • 208 ارسال

ارسالی 1388/04/23 ساعت 14:42

منم دوست دارم این مشکلم حل شه اینم ایدی بنده اگه مشکله منم حل کنید ممنون می شم

[email protected]
  • 0

#16 Guest_parsianserver_*

Guest_parsianserver_*
  • میهمان

ارسالی 1388/04/23 ساعت 14:58

دوست منم اینم سایت منه
http://www.sibesorkh.ir/
نمیدونم چی کار کنم میتونی کمکم کنی
اینم ای دی منه
mr.birtaz
  • 0

#17 mob2ni

mob2ni

    کاربر فعال انجمن

  • عضو سایت
  • ستارهستارهستاره
  • 208 ارسال

ارسالی 1388/04/23 ساعت 16:15

ولی ساحر جان replaceفکر کنم به درد نمیخوره چون من چک کردم و دیدم که حرف ژ هم به این شکل است ؟ من فقط فکر کردم !!
  • 0

#18 mob2ni

mob2ni

    کاربر فعال انجمن

  • عضو سایت
  • ستارهستارهستاره
  • 208 ارسال

ارسالی 1388/04/24 ساعت 13:54

دوستان زحمت نکشن تا شما بیایین جواب بدین خودم نشستم تک تک پست ها رو ویرایش کردم بازم ممنون از راهنماییتون happy دیتالایف انجینی ها گل هستند ( دستمال یزدی )
  • 0

#19 fttp

fttp

    عضو جدید

  • عضو سایت
  • ستاره
  • 18 ارسال

ارسالی 1388/08/03 ساعت 09:31

سلام
منم همین مشکل رو واسه حرف ج دارم
تمامی کلماتی که حرف ج دارن به صورت یه مربع دیده میشن
اما مشکل من تو قالبه نه مطالب
از قالب های دیتالایف انجین هستش من که خودم زور زدم نتو نستم اینو حلش کنم، اگه کسی بلده راهنمایی کنه لطفا...
  • 0




1 کاربر در حال خواندن این موضوع است

0 کاربر، 1 مهمان و 0 عضو مخفی